Fare calcoli e conteggi senza usare la calcolatrice, ma tenendo traccia di tutte le operazioni. I fogli di calcolo di Microsoft Excel sono uno strumento efficace sia per chi ha bisogno di fare un bilancio familiare e tenere traccia delle bollette da pagare, oppure per chi li utilizza per lavoro. Le formule Excel del programma di Microsoft Office sono molte e permettono di svolgere sia calcoli semplici che complessi, oltre che creare grafici. Per chi ne fa un uso base, ci sono 12 funzioni sempre utili e da conoscere: scopriamole insieme.

Formule Excel: come eseguire la somma

sommaLa funzione Somma permette nei fogli di calcolo di Excel di sommare i numeri presenti all’interno di un intervallo di celle definito dall’utente. Si può usare il simbolo matematico dell’operazione

= A1 + A2 + A3 + A4

Oppure una formula che permette con poco tempo di sommare anche grandi intervalli di numeri

=SOMMA(num1;num2;…)

dove num indica l’intervallo di celle a cui si vuole applicare la formula per sommare i numeri al loro interno. Ad esempio, se si vogliono sommare i numeri che si trovano nelle celle da A2 ad A10, la formula da usare è:

=SOMMA(A2:A10)

mentre per sommare i numeri di diverse celle in più colonne, si può inserire un secondo num

=SOMMA(A2;B2:B10;C13)

questo esempio permette di sommare i numeri presenti nella cella A2, nelle celle da B2 a B10 e nella cella C13.

Formule Excel: come eseguire il prodotto

prodotto excelMoltiplicare e dividere sono le altre due operazioni fondamentali da fare con Excel e ci sono due modi per farlo. Il primo è utilizzare i segni matematici * e /, digitando nelle celle

=A1 * A2 * B3 * B4

Esistono però anche delle formule Excel che permettono di calcolare il prodotto di un intervallo di celle in modo più veloce

=PRODOTTO(num1;num2;…)

Formule Excel: come calcolare la media

media excelQuando si vuole ottenere la media matematica di più numeri, Excel offre una pratica formula. La sintassi è simile a quella della somma, ma stavolta bisognerà utilizzare questa formula

=MEDIA(num1;num2;…)

dove gli intervalli di celle vengono gestiti esattamente come per la somma.

Formule Excel: come trovare il valore alto o basso

massimo minimo excelQuando si sta analizzando i numeri di diverse celle, si potranno utilizzare le specifiche formule Excel per definire il valore più alto e più basso presenti. Le funzioni da usare in questo caso sono:

=MAX(num1;num2;…)

per trovare il massimo, cioè il numero più alto tra quelli presenti in un intervallo di celle, mentre

=MIN(num1;num2;…)

permette di identificare il valore minimo tra quelli presenti in più celle.

Formule Excel: come trovare il valore intermedio

mediana excelOltre al massimo e al minimo, si potrebbe voler trovare in modo semplice e veloce il valore intermedio di un certo intervallo di celle. Per farlo, Excel offre una specifica funzione che è simile a MIN e MAX

=MEDIANA(num1;num2;…)

Con questa formula, verrà restituito il valore mediano di tutti i numeri presenti nell’intervallo di celle selezionato come num dall’utente.

Formule Excel: come contare le celle di un intervallo

excelUn'altra funzione che vale la pena conoscere è quella che permette di contare le celle di un intervallo. Pensate a quando si fa una lista di invitati a una festa o un evento. Ogni cella conterrà un nome e si vogliono contare le persone invitate. Per farlo, è possibile usare la formula Excel

=CONTA.XXX(num1;num2;…)

dove la con XXX si intende una diversificazione della funzione a seconda di cosa si vuole contare:

  • =CONTA.NUMERI, conta il numero di celle dell’intervallo che contengono numeri
  • =CONTA.VALORI, conta il numero di celle non vuote che contengono testo o numeri
  • =CONTA.VUOTE, conta il numero di celle di un intervallo che sono vuote

Formule Excel: come arrotondare per eccesso o per difetto

arrotonda excelQuando si eseguono operazioni coi fogli di calcolo si possono ottenere numeri decimali con molti numeri dopo la virgola. Per ottenere un foglio più ordinato, esistono apposite funzioni che permettono di arrotondare per eccesso o per difetto, oppure troncare il numero a una certa lunghezza.

Per arrotondare il numero ottenuto in una cella si può usare la funzione Excel

=ARROTONDA(num1;num_cifre)

dove num1 è l’intervallo di celle che si vogliono arrotondare e num_cifre il numero di cifre di cui il valore verrà arrotondato per eccesso o difetto. Come per la funzione CONTA, esistono diverse funzioni aggiuntive che permettono di eseguire l’arrotondamento sempre per eccesso o sempre per difetto, al numero intero più vicino. Quando invece si vuole troncare un numero decimale ed eliminare i valori dopo la virgola, si può usare la funzione

=TRONCA(num1;num2;…)

Formule Excel: come inserire data e ora correnti

adesso excelChi vuole visualizzare sempre l’ora e il giorno corrente all’interno di un foglio di calcolo potrà farlo in modo molto semplice con l’apposita formula Excel

=ADESSO()

dove non è necessario inserire un num perché il foglio di calcolo recupera in automatico l’ora e la data a cui è aggiornato il computer.

Formule Excel: come usare il numero di riferimento di una cella

righe excelQuando si deve navigare nel foglio di calcolo, si potrebbe aver bisogno di indicare il numero di riferimento di una cella. Esistono due apposite formule Excel da utilizzare in questo caso

=RIGHE(num)

per indicare il numero di riferimento di una o più righe del foglio di calcolo.

=COLONNE(num)

per indicare il numero di riferimento di una o più colonne.

Formule Excel: come eliminare lo spazio vuoto

annulla spazi excelQuando si incolla un argomento all’interno delle celle dei fogli di calcolo di Microsoft Excel potrebbero esserci anche degli spazi vuoti. Per rimuovere gli spazi vuoti dal foglio di calcolo si potrà usare la formula Excel

=ANNULLA.SPAZI()

che permette di rimuovere gli spazi vuoti in eccesso in una stringa di testo eccetto gli spazi singoli che separano le parole.

A cura di Cultur-e Costruisci il tuo futuro con la connessione Fastweb